.NET 2.0 compatible version?

Jul 8, 2010 at 9:46 PM

I recently upgraded from VS2005 to VS2010. 

Unfortunately VS2010 will not let me use InputSimulator.0.1.0.0-bin in my .NET 2.0 based project, it says that it's build for another version of the .NET framework.

Then I downloaded the source of the original release (InputSimulator.0.1.0.0-src.zip) intending to build it for .NET 2.0, but indeed there are .NET 3.0 dependencies (Linq among others).

The strange thing is that the bin is working on .NET 2.

Can someone shed some light on this matter?

Thanks

Jul 12, 2010 at 5:05 AM
Hi,

Sorry I didn't reply earlier.  There's a few ways to swing this answer. 

VS2010 allows you to target different CLR/runtime versions.  If your project is supposed to target the .NET 2.0 runtime you can reference InputSimulator.0.1.0.0 in your VS2010 project and make sure the target of your project is also .NET 2.0.

As far as the .NET 3.5 dependencies of Linq etc, you can still reference an assembly compiled for the same runtime.  So anything from .NET Framework Version 2.0 through to Version 3.5 SP1 all use the CLR 2.0 (as confusing but cool as that is).  I've build a couple of projects that were built using .NET Framework version 2.0 which reference .NET Framework version 3.5 assemblies.  The proviso is that your target runtime environment must have .NET Framework version 3.5 installed.

If you are happy to target the .NET Framework 4.0/CLR 4.0 you can take either version of InputSimulator (0.1 or 0.2) and use those happily.

Failing all of that you can very quickly remove any dependency on Linq by taking the 0.1.0.0 code and writing foreach loops instead of the Linq statements.  This will make it a purely .NET framework version 2.0 release.  :)

Kind Regards,
Mike

On Fri, Jul 9, 2010 at 6:46 AM, soeren123 <notifications@codeplex.com> wrote:

From: soeren123

I recently upgraded from VS2005 to VS2010. 

Unfortunately VS2010 will not let me use InputSimulator.0.1.0.0-bin in my .NET 2.0 based project, it says that it's build for another version of the .NET framework.

Then I downloaded the source of the original release (InputSimulator.0.1.0.0-src.zip) intending to build it for .NET 2.0, but indeed there are .NET 3.0 dependencies (Linq among others).

The strange thing is that the bin is working on .NET 2.

Can someone shed some light on this matter?

Thanks

Read the full discussion online.

To add a post to this discussion, reply to this email (inputsimulator@discussions.codeplex.com)

To start a new discussion for this project, email inputsimulator@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Jul 12, 2010 at 10:54 AM

Thank you for the reply.

I need a pure .NET 2 release so I've replaced the linq code.

If anyone else needs this version please let me know.

Best regards

Soeren

 

Feb 8, 2012 at 1:41 PM

hey is it possible to obtain the 2.0 Version?